icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.lysyoga.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

pk10助赢 www.007780.cc-澳客彩网-| www.229590.com-481彩走势图| www.777651.com-大地合买彩票源码| www.905996.cc-篮球竞彩计算器| www.976524.com-2018年太原彩礼| www.cp8979.com-爱彩乐快三-| www.1410.me-开乐彩那里有卖| www.985613.com-竞彩专家单场推荐| www.nl08.com-杨震足彩推荐| www.17zu.com-体彩大乐透历史同期| www.2933.pw-安阳体彩中心地址| 万利www.32123g.com| www.388466.com-3d遗漏分析中彩网| www.141843.com-彩票手机号选号器| www.233078.com-竞彩足球app推荐| www.577629.com-七星彩必赢网| www.83331.cc-中国职业彩票玩家| www.138081.com-非法彩票app| www.214330.com-人人竞彩手机版| www.283225.com-彩票是怎样的玩法| www.710158.com-彩民之家总站| www.818754.com-彩站彩票欢迎光临| www.897076.com-彩票超级稳计划| www.973899.com-幸运五星彩开奖视频| www.cp0212.com-苹果快三助手下载| www.821308.com-福彩3d大兵鬼魂图| www.036255.com-快三算法大小单双句| www.89849.com-体彩排列跨度振幅| www.09686.com-天天福彩彩友沙龙| www.si76.com-乐8彩下载安装| www.34dv.com-龙港之彩印刷| www.323523.com-今天七乐彩开奖直播| www.42242.cc-分分彩挂机方案论坛| www.097187.com-福彩小鱼图反正面| www.586394.com-免费领取38彩金| www.663359.com-上海快三2码遗漏| www.736297.com-彩票私带回血上岸| www.810446.com-7乐彩开奖历史| www.880849.com-返水高的彩票网站| www.10852.com-亚洲杯中奖彩票| www.375723.com-安徽宣城彩票中奖| www.528270.com-彩神v外挂下载| www.660627.com-七彩直播破解版下载| www.763461.com-彩票十选五开奖结果| www.864062.com-今天体彩开奖号码是| www.76956.com-9号彩票登录地址| www.443411.com-网上彩票还能恢复吗| www.540168.com-外围和国彩哪个好| www.615237.com-女孩玩福彩快三| www.698962.com-美国彩票怎么买| www.778370.com-厦门福彩快三| www.899606.com-彩81平台网站| www.960538.com-快三7点和值多少钱| 聚福彩票www.50989g.com| www.457443.com-关于买彩票不中诗句| www.598872.com-网络彩票源码| www.692680.com-乐米彩票正规吗| www.796501.com-头彩网官网下载| www.887953.com-需要推广彩票的老板| 豪彩VIPwww.hong663.com| www.302981.com-优乐彩网站靠谱吗| www.840923.com-彩妆加盟开店| www.914947.com-大发博彩老板| www.971897.com-彩拾网站-| 大赢家彩票平台www.805681.com| www.rl20.com-新西兰快三走势图| www.66lp.com-七星彩庄家打印单| www.11553.com-彩尊-| www.58733.com-天天时时彩官网| www.109368.com-被金利彩票骗了| www.887230.com-上淘快三开奖结果| www.cp5563.com-3分快三开奖结果| www.wq51.com-如何看彩票趋势图| www.25yr.com-彩票代销违法吗| www.819.live-彩票开奖延时| www.4998.cn-福逮体彩网开奖查询| www.08180.com-振幅彩票术语| www.51063.cc-福利彩三试机号查询| www.8897.xyz-竞彩有8串多少| www.237845.com-5分快三合法吗| www.316166.com-彩票终端机加盟| www.16283.cc-足彩资讯平台| www.003587.com-为啥有钱人不买彩票| www.086767.com-菲律宾合法彩票平台| www.5319.biz-qq彩色气泡代码| www.26757.com-网投快三刷水钱方法| www.78353.cc-优优彩票网是真的吗| www.je54.com-119彩票安卓下| www.r91.cn-山东体彩中心电话| www.59yt.com-彩票店招-| www.7878.vip-智胜彩票平台| www.52527.cc-好彩赚钱平台| www.fu88.com-计划群带着买彩票| www.7120.pw-七彩孔雀建盏| www.53875.cc-时时彩组六全包技巧| www.577591.com-福彩三d图谜第二版| www.1nk.com-玩彩票违法吗| www.81su.com-工行积分怎么换彩票| www.1772.cc-福彩3布衣图库| www.6446.pw-双色球字谜彩宝贝| www.11551.cc-八亿彩软件是什么| www.45589.com-福彩3d大小振辐| www.70wo.com-彩易达渠道部| www.6039.vip-云南省体彩中心主任| www.454567.com-乐彩是不是真的| www.537720.com-国彩在线下载| www.760753.com-东北结婚彩礼| www.871842.com-利彩首页-| www.925551.com-旭彩美缝剂厂家| www.972478.com-优优购彩有人玩吗| 大赢家彩票平台www.226705.com| www.js89.cc-神彩88-| www.78712.cc-亚博怎么买彩票| www.052513.com-彩神v怎么玩才会赢| www.cp5527.com-北京快三推荐预测| www.572673.com-东盛彩报3d-| www.702088.com-足彩足球-| www.807021.com-彩易科思回收彩票| www.691400.com-竞彩天天手环| www.114878.com-彩票计划网址| www.141480.com-广州鸣彩艺术品骗局| www.213283.com-拼搏在线彩票开奖| www.8425.cm-快三咋样才能中奖| www.940445.com-快三平台真假| www.325005.com-福利彩票三地字谜| www.22341.com-168彩票开奖结果| www.hl02.cc-福彩1d稳赚-| www.021777.com-体育竞彩app排行| www.675375.com-宏盛彩票正规吗| www.838203.com-快三怎么定胆码| www.988542.com-57彩票app-| www.ue97.com-凤凰私彩平台官网| www.53sj.com-福建彩票每月任务| www.168040.com-快三网站是真的吗| www.887908.com-天天好彩246网| www.968537.com-体彩排例三开机号| www.bi55.com-网易彩票是正规的吗| www.s99.site-郑州彩票大奖| www.60wt.com-网易彩票吞钱吗| www.3787.vip-彩先知谜语解特马| www.12678.cc-体育彩票能中奖吗| www.77440.com-体彩软件哪个软件好| www.027904.com-多彩投众筹平台官网| www.718935.com-羽泉彩虹-| www.003924.com-足彩比分预测分析| www.7629.xyz-荣耀彩票app| www.76sh.com-宁夏快三破解| www.4093.biz-彩虹9无人机| www.205173.com-内蒙古彩票快3开奖| www.560079.com-kk彩票网官网| www.126748.com-在彩票平台赢钱了| www.387189.com-987彩票真的假的| www.n10.xyz-668彩票下载| www.034932.com-彩票71是什么意思| www.31925.cc-意彩足球比分| www.503983.com-走台和彩排的区别| www.632469.com-福利彩票投注站注销| www.316912.com-福彩3d助手app| www.511579.com-合肥彩票官网| www.029918.com-内蒙快三的玩法| www.418822.com-竞彩店兑奖额度| www.521198.com-探探的套路买彩票| www.079006.com-七星彩1976期| www.519692.com-快三高手稳赚技巧|